3D MOOCs Studio

Rapid Development of Interactive and Educational 3D Content
3D MOOCs Studio

**Objective:** Rapid development of 3D Interactive educational content to provide educators in STEM disciplines or MOOCs production support specialists with easy means to make their courses and exercises more engaging online and in the classroom.

**Participants will learn to:**

- Embed 3D content from any CAD software into online or in-class course material, and design 3D visualization sequences in support of specific learning objectives
- Manipulate and fully understand the structure of the complete “3D MOOCs Studio” toolset

**Format:** Rapid introduction and step-by-step hands-on exercises using SOLIDWORKS Composer with wind turbines case.

**Pre-requisites:** Familiarity with MS-Office layout

**NOT pre-requisites:** PLM or any CAD knowledge, MOOCs knowledge
## 3D MOOCs Studio

**Table of Contents**

- **Introduction**: MOOC Studio vs. 3D MOOC Studio
- **Authoring tool**: SOLIDWORKS Composer
- **Hands-on**: “Wind turbine” and “Lego Space Man” use cases
- **Learn more**: E-learning courseware
MOOC Studio vs. 3D MOOC Studio

- Lecture
- Exercise
- Textbook
- Lab
- Problem
MOOC Studio vs. 3D MOOC Studio

3D MOOCs Studio to integrate interactive 3D animations in conjunction with video, audio or text files.
3D MOOCs Studio: **WHAT**

A place to Quick Start Educator’s 3D capabilities

**COLLECT 3D Data**
- Web connexion to access online 3D libraries (ex: 3DVIA.com)
- 3D CAD software (CATIA, SOLIDWORKS…)

**PRODUCE**
- Computer operating SOLIDWORKS COMPOSER

**ENRICH**
- Microphone & Voice recording / editing software (audacity…)
- Video recording facility / video editing software (Camtasia)

**EMBED**
- MS Office,
- (Adobe reader)

**PUBLISH**
- Web connexion to publish online, and upload to any website.
3D MOOCs Studio: WHAT

Endless Learning Subjects

Types of Learning fields

- Learning Odontology in 3D
  Health sciences: LYON I

- Learning Geology in 3D
  ENIM/UPMC

- Learning Crystallography in 3D
  Lasalle Bauvais (Geology)

- Learning Technology in 3D
  Educators from STI2D & FRANCE CRAFT

- A gallery of 3D Elementary Learning Objects

Deployment

3D MOOCS Studio
SOLIDWORKS Composer

Easy to PRODUCE online interactive 3D content

► Reuses 3D files in various CAD or neutral formats, made by course authors or available on internet:
  • 3DVIA.com: http://www.3dvia.com/
  • GRABCAD: https://grabcad.com/home
  • 3D CONTENT CENTRAL: http://www.3dcontentcentral.com/default.aspx

► Easy creation of learning sequences using Story Telling (Slide or Camera Movement)

► Produced 3D can be learner-animated in real time or animation can be pre-defined by author

► Produced 3D can be enriched by various additional information or behaviors: Annotations, cutting tools, dynamic measurements, zoom/pan, translation, rotation, explosion, graphic property, Kinematic, Bill Of Material,…
SOLIDWORKS Composer

Easy to **SHARE** interactive 3D content

- Produced content can be viewed by any learner:
  

- Various formats: 3D interactive animation, 3D predefined animation, video, image, Stereoscopic 3D (with specific device)

- Various embedding documents: Powerpoint, Word, PDF, HTML.

- Various distribution means:
  
  - Online on own website or on public 3DS Academy
  - Standalone executable package
  - DVDs/CDs.
SOLIDWORKS Composer

GO TO THIS LINK TO DOWNLOAD PLAYER, IF NEEDED:
http://www.3ds.com/products-services/3dvia/3dvia-composer/resource-center/

3D VIA Composer Player ActiveX

http://www.3dvia.com/products/3dvia-player/install/
Hands-on Exercises

Wind turbine use case
Procedure: Collect, Produce, Publish
Open a 3D model

1. Open **SOLIDWORKS Composer**. A blank window opens.

2. **Drag and drop** your model in **SOLIDWORKS Composer**.

3. After a quick conversion, your 3D model is loaded and ready to use.
User Interface

*SOLIDWORKS Composer* has an **Office 2007 based layout**, giving access to all the tools.

- Ribbon (1)
- Views panel (2)
- Properties panel (3)
- 3D model (4)
- Timeline (5)
Create views

Your wind turbine is now opened in **SOLIDWORKS Composer**. First, let’s focus on the blank upper layer of the ground.

1. **Left-click the grey layer** to access its actor properties panel on the left.
2. **Enable** the texture.
3. Click the three dots along **Map path** to browse your computer and find an image that will be applied to the ground. To help you, you can search [**field satellite view**] on Exalead.
Create views

4. Reduce the Shininess of the ground to 1 to make it more realistic.

5. Click the Create View button in the Views panel to Create the view.

6. Rename it [Start] by pressing F2 while selecting the view.
Create views

You can **change the point of view** to have a better overall appearance.

1. Right click and hold to **rotate the camera** around the model.
2. **Pan the model** by holding middle click.
3. **Zoom the model** by mouse scrolling over it.
Create views

To apply changes, you have to update the view:

- Click the Update View button while selecting a view.

  or

- Right-click a view and click Update View.

Try to remember how to create and update views, you'll only be notified to create/update from now on.
Create views

To transform this Start view into a real application starter:

1. Make sure that you are in View Mode by checking the icon on the top left corner.
2. Make sure that the Design Mode is highlighted.
3. In the ribbon, select the Author tab, click the arrow along the Image 2D icon and select All buttons.
Create views

4. Left-click anywhere on the model to place the button.

5. Resize it by dragging one of its corners.

6. To finish, drag it to the bottom by holding left-click.

Don’t forget to update the view once you are done.
Create views

Now you have to create the second view. It will be a close up of the wind turbine introducing what the application was made for.

1. Create this view and rename it [Intro].
2. In the Home tab, open the Align Camera menu.

Don’t forget to update the view!
Write text

4. In the **Intro view**, select the **Author** tab and click the **Text 2D** button.

5. Click at the bottom of the view to place the canvas and write *[Let’s see how a wind turbine works]*.

6. The text is too small so you can **increase the font size** thanks to its **Properties panel** (size 24 is recommended).

7. **Update** the view.

You can **move** a 2D Text like you move a button. You can use a Digger, press “space bar”.
More authoring tools

Now you have to create a third view for the application, showing the different parts of a wind turbine.

1. Select the text, and press “h”
2. In the Author tab, click the Label button.
3. This tool allows you to place a contextual label that will automatically adapt its content to the pointed element.
4. Rotate the view so that it looks like the picture opposite.
5. Click the Nacelle, the Tower and one of the Blades to create labels.
6. Create this view and name it [Parts].

Like all SOLIDWORKS Composer actors, Labels have their own properties that can be modified.
Move parts

7. To move parts, click the **Free Drag** button in the **Transform** tab of the ribbon.

8. **Move** the elements you want by dragging them across the screen.

9. You can translate and rotate selection by clicking **Translate** or **Rotate**, and move the selection around or along the desired axis.

10. If you made a mistake, click **Restore Neutral Position** button.

---

Don’t forget to create/update the view!

A. Axis when translating

B. Axis when rotating
Move parts

In the fourth view, you will move parts to show the inside of the wind turbine using a different tool than the classic translate.

1. Select the three labels (holding Ctrl key), and press “h”. Save this view as [Parts2].
2. Enable Assembly Selection Mode in the Assembly panel.
3. Select these parts (hold Ctrl key for multiple selection).
4. Click on Linear button in the Transform tab of the ribbon.

The blue frame on the model indicates that you are in Assembly Selection Mode.
Move parts

Three axis appear on the model. You can **explode the model** along those.

1. Click the red axis, and **explode** the upper part of the wind turbine along it.

2. **Explode in the other way** to show the upper part exploded in both ways.
Move parts

To improve the point of view for Parts2, you will select parts to reframe.

1. Exit the Assembly Selection Mode by clicking its icon in the Assembly panel.
2. Click the No Transformations button in the Transform tab to deactivate part moving.
3. Select these parts.
4. Select the Home tab and in the Align Camera menu, click Right/Left.

Don’t forget to update the view!
Move parts

5. **Create a label** on the **Generator** and one on the **Primary Carter**. Make sure that the label is related to the **assembly** (Gearbox) and not only to the Carter.

6. **Click on Primary Carter label** properties, and change its **Parent (level)** to **Gearbox**.

7. **Check that the Text property is Name** (Actor.Name).

---

Don’t forget to **update** the view!
Create views

1. Go to the **Views panel** and switch to the **Assembly panel**.

2. **Select the actors** highlighted (see opposite) by holding the **Ctrl** key while clicking them.
Create views

3. In the ribbon, select the **Author** tab and click the **create** icon on the Cutting Planes panel.

Don’t forget to **create** the view!
Create views

4. Click at the top of **Nacelle**

5. **Drag** the cutting planes to the **middle of Nacelle**
Create views

6. In the ribbon, select the **Author** tab, click the arrow along the **Distance Angle** icon and select **Distance Between 2 Points**.

Don’t forget to **create** the view!
Create views

7. Click at the top and the bottom of the Wind Turbine
8. Click where you want to put the measure
Play your 3D experience

To test the application, check the different buttons.

1. Make sure that you are in **View Mode**.
2. Make sure that **Design Mode** is not highlighted.
3. Double click on **Start** view to switch to the Start view.
Play your 3D experience

4. Click the **Next button** and watch your first interactive animation!

5. On each view, click the **Next button** to go to the next one.
Packaging your application as an executable

Now you are going to **export your application** so that everybody will be able to **see it** without having to **install** any software.

1. Click **File > Save As > Package**

Your file is an **executable**, which means that anyone using a Windows computer can run it **without installing anything**.
Embed it in a PowerPoint

Now you will export your application so that you can embed the whole animation in your PowerPoint presentation.

1. Launch PowerPoint.
2. Right Click on a ribbon.
3. Click on Customize the Ribbon.
4. In Main Tabs, check Developer.
5. Press OK.
Embed it in a PowerPoint

6. Click on the Developer Ribbon.

7. Click on More Controls icon.

8. Click on Composer Player Activex.

9. Draw a square in your slide.
10. Right click the **Composer window** in your PowerPoint.

11. Click **Composer Player ActiveX Object**

12. Click **Properties**.

13. Check in **Pack SOLIDWORKS Composer document**. Click the **three points** to browse and find your **SOLIDWORKS Composer** file.

14. Press **OK**.
Embed it in a PDF

Now you will export your application so that you can distribute it to everybody in a PDF file.

1. Click on File > Publish.
2. Click on PDF.
3. Save your file and close SOLIDWORKS Composer.
Additional Exercice

Make your own application with LEGO Space Man
What’s next?

The previous steps explained you **how to create** an animation with simple views.

But **SOLIDWORKS Composer** allows **many more actions**. The animations we created are transitions.

You will now see how to recreate a part behavior, and how to **simulate complex mechanisms**, such as epicyclic gear.
Start a new project

1. Open **SOLIDWORKS Composer**.
2. Drag and drop your model into **SOLIDWORKS Composer**.
Start a new project

3. Left-click the grey layer to access its actor properties panel on the left.

4. Enable the texture.

5. Browse your computer and apply again the ground texture.

6. Set the Shininess to 1.
Introduction to kinematics

*SOLIDWORKS Composer* is able to create kinematic mechanisms.

Several constraints need to be respected:

- Kinematic links are defined between a child and its parent.
- Children can have only one parent.
- Parents may have several children.
- Five types of kinematic links may be applied to a child:
  - Free (default)
  - Pivot
  - Spherical
  - Linear
  - Rigid
- Kinematic links are based on the compass (pivot) you can see when you translate or rotate a part.
- Pivots can be edited with the tools in the Transform tab.
Introduction to kinematics

1. To define the **Parent/Child relationship**, **drag** the child onto its parent.

2. Then, you can change the **kinematic link**.

A parent can **move** its children, but a child can’t **move** its parent.
View Mode vs. Animation Mode

Since the beginning of this course, you have been working in View Mode.

► The View Mode is the easiest to use but working under the Animation Mode allows more complex animations and kinematic behaviours.

► Animation mode enables you to make continuous movements and design the application exactly the way you want it.

► Working in Animation Mode implies that you work directly on the Timeline.
Timeline

The Timeline is a simple but very powerful tool.

It contains:

- the Actors Track (1)
- the Camera Track (2)
- the Digger Track (3)
- the Marker Track (4)

The Marker Track defines the sequences that will be played. Each marker is a breakpoint.

On each track, a key (5) stands for a property. If there are multiple properties set at the same time, they are all grouped under the same key.

To filter grouped properties, you can use the three key filters (6):

- Show Keys for Selected Actors Only
- Show Keys for Selected Properties Only
- Show Location Keys Only

The Auto-Keys allows the automatic creation of keys.
Complex animations

► Now, you have to show how an **epicyclic gear** (the one inside the wind turbine) works.

► The animation will last 30 seconds during which the wind turbine will spin and you will progressively get inside it until you reach the epicyclic gear.

► Thanks to the kinematic links, **you will master the complex animations** of epicyclic gear.
Complex animations

To begin, you have to prepare several things.

1. Click the **Animation** button in the **Home** tab to access the **Animation Mode**.

2. **Select** all these parts.

3. In the **Home** tab, open the **Align Camera** menu and select **3/4 X+ Y- Z+**.
Complex animations

4. Click **Set Camera Keys** on the Timeline to **Save the camera position**.

5. In the **Assembly Panel**, drag and drop the **Rotor** onto the **Gearbox**.
Complex animations

6. Drag and drop the Rotor onto the Input Shaft.

7. Select the three “Planet” and drop them onto Input Shaft.

8. Repeat the procedure with the Planet Carrier.
Complex animations

Now you have to set up the kinematic links.

1. In the Assembly panel, select the Planet Carrier to access its Properties panel.
2. Change it to Rigid.
3. Activate Assembly Selection Mode.
Complex animations

4. Select the **Rotor**, and set its **Link type** as **Rigid**.

5. Select the three '**Planet**', and set their **Link Type** as **Pivot**.

6. Set **Link Axis** as **Y+**.
Complex animations

To facilitate the creation of animations, you can change several settings.

1. In the Assembly panel, uncheck Wind turbine.

2. Check:
   - the Input Shaft,
   - the Output Shaft
   - the Annulus.

3. Uncheck the Planet Carrier.

4. Deactivate the Camera Play Mode on the Timeline.
Complex animations

Now you can clearly see which part is moving.

1. **Play**, and **move the camera to see the epicyclic gear working**.

2. To browse the model during the animation, activate the **Camera Play Mode**.
Complex animations

Now you are ready to create the real animation.

1. Select Input Shaft.
2. In the Transform tab, click the Rotate button.
Complex animations

4. Scroll down the mouse on the Timeline so that you can see 30.0”.

5. Click under the 30.0” mark to move the time cursor and work at that time.
Complex animations

6. Click the **plane** orthogonal to the **green axis** to make the wind turbine spin.

7. In the **Properties panel**, enter **[1800]** for the **Angle**. **SOLIDWORKS Composer automatically creates keys** on the **Timeline**.
Complex animations

8. Select one of the three 'Planet' and activate the **Show Parent Axis** option.

9. Rotate around the green axis and enter [-7200] for the **Angle** value.

10. Repeat Step 2 for the remaining Planets.
Complex animations

1. Exit Assembly Selection Mode.
2. Deactivate the Show Parent Axis toggle.
3. Check Output Shaft.
4. Once again, rotate it around the green axis. Enter \([10800]\) for the Angle value.
5. Check the Wind Turbine in the Assembly Panel.
Animation finalization

1. Click on the **Timeline** to Set time at **3.0”**

2. **Don’t move the camera** and click on on the **Set Camera** button to save the camera position.

3. Move to **5.0”**.

4. Select the **Nacelle** and the **Cone** and click **Zoom Selection**.

5. Set a **new camera key**.
Animation finalization

1. Move to 7.0" and select:
   - the Cone
   - the Cache
   - the Nacelle

2. Open the Effects menu of the Timeline thanks to the arrow and select Fade Out.

3. Move to 10.0" and Set Camera Key and select:
   - the Generator
   - the Primary and Secondary Carters
   - the two Main Bearings

5. Apply a Fade Out effect.
Animation finalization

1. Move to 14.0” and select the Primary Carter > Zoom Selection > Set Camera Key.
2. Select the Planet Carrier and apply a Fade Out effect on it.
3. Move to 18.0” and set a new camera key.
4. Move to 23.0”.
5. In the Assembly panel, select all the model except the Ground > Zoom Selection > Set another camera key.
Animation finalization

6. To finish, apply a **Fade In** effect to these parts.
Animation finalization

Now you have to add a **Start button** to the final application.

1. Select the **Author** tab and click **Next button** in the **Image 2D** menu.
2. **Rewind** the Timeline.
3. Place it on the **middle of the screen**.
Animation finalization

4. Set the time at 0.5” on the Timeline and apply a **Fade Out** effect to the button.

5. The button won’t play if you don’t place a marker to define the **Marker Sequence**. Set a marker at 30.0” and click on “New Marker” to rename it [End].

6. Your application is now **ready** to work! Don’t forget to disable **Design Mode** if you want to test it.
Publish your work on 3dvia.com

**SOLIDWORKS Composer** allows you to publish your work on 3dvia.com in a few clicks.

1. Click **File > Publish > 3dvia.com**.
2. A login window pops up.
3. **Authenticate** yourself.
Publish your work on 3dvia.com

1. Your browser opens your 3dvia.com dashboard. **Keep the browser open until your file has been uploaded!**

2. Your model appears on your dashboard.

3. Click it to access its own description page.
Publish your work on 3dvia.com

1. Click **Edit > Edit Attributes** to edit the model’s title, tags, description…
Publish your work on 3dvia.com

1. To make your 3D Experience available for everyone, set the Audience as Public.

2. Scroll down the page, and click the Save button. You will be redirected towards the model’s page.
Publish your work on 3dvia.com

To watch the result online, click **Use Composer Player**. Make sure you are browsing with Internet Explorer!

Enjoy your **online application**!
Learn more

A complete E-learning courseware is available on the Academic website: http://academy.3ds.com/learning-materials/